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Overview 

The purpose of this document is to guide the developer in the use of the operating interfaces that allow 

configuration of the behavior of the ITSCAM 600, ITSCAM 600 FHD, VTR 600, ITSCAM 450 and ITSCAM 

450+ devices. This document details the options available via the web interface, the Pumatronix Protocol 

or the Cougar Protocol. 

 

Depending on the firmware version applied to the device being accessed, the web access 
interface differs and some functions may only be available in the latest versions. 
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1. Presentation of the Web Interface 

The Web interface makes it possible to evaluate the images generated and configure the devices. Access 

to the interface requires information: 

User admin 

Password 1234 
 

 

Figure 1 - Login screen 

As a form of security, it is recommended to change the device's default password by accessing the System 

> Users menu: 

 

Figure 2 - Screen displayed when accessing System>Users 

1) Click on Edit: 
2) Enter a Name and create a new Password, which can contain between 4 and 200 characters, 

including numbers, letters and special characters; 
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3) Finish by clicking on Apply: 

 

Web Interface Help 

If there is any doubt about any setting on the web interface, there is a help symbol which, when placing 

the cursor over it, displays an explanation, examples or the recommended setting for the device: 

 

Figure 3 - Help displayed by positioning the cursor on top 

 

 

Figure 4 – Interface help 
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Home Screen 

The home screen displays the Current Status screen of the device in operation, as well as the permanent 

usability options on the interface: 

 

Figure 5 - Options available on the interface and in the Current Status window: 1) Menu bar; 2) Action 

button available for functionality; 3) Pop-up live view window; 4) Equipment data, including detailed 

Runtime and quick setting buttons, 5) Data on installed firmware versions 
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Figure 6 - Available data on the Current 

Status of CPU, Memory and Storage 

Performance 

 

Figure 7 - Available data on the Current 

Status of Camera and GPS Services* and 

port connections 

* When the device is able to establish communication with a GPS network, the main Geolocation information is 

displayed as the Figure 7 above. 

Changing the Interface Language 

The Web interface can be displayed in Portuguese or English by selecting it on the login screen or by 

accessing it from the Equipment > General menu. 

 

Figure 8 – Equipment > General menu screen 
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2. Usability Settings 

 

The steps for configuring the image capture devices are presented in the ideal order of 

settings and must be carried out after physical installation, respecting the Prerequisites 
and Necessary Conditions for installation presented in the Product Manual. 

Network Settings 

Network settings require the use of an Auxiliary Configuration Equipment. 

1) Enter the factory default IP address in the browser; 
2) Enter user admin and password 1234; 
3) Access the menu Equipment > Network; 
4) Access the tab for the network to be configured. 

The initial network settings screen allows to visualize the Status of the connected networks and the diagram 

of the configured Routes: 

 

Figure 9 - Network settings home screen 
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Ethernet Network Settings 

Some models of the ITSCAM 600 device have only one Ethernet connector, and the ITSCAM 600 FHD 

devices have 2 Ethernet connectors. For the ITSCAM 450 and VTR 600 there is only 1 Ethernet interface 

for settings: 

1) Select the Ethernet tab; 
2) Identify the network in Hostname; 
3) Fill in the data for the Primary Interface (ETH-1) when connecting to ETH-1; 

a. Use a different IP address to the one used to access the device in order to avoid conflicts 
and malfunctioning of the data network; 

 

The maintenance IP (192.168.254.254) is used to recover the connection in 

extraordinary situations when the primary IP is lost. For this reason, when manually 
configuring the device's network interface (Ethernet or Wi-Fi), values other than the 

maintenance IP must be applied. 

4) Click on Apply after confirming the data entered: 

 

Wi-Fi Network Settings 

Only the VTR 600 devices and some models of the ITSCAM 600 and ITSCAM 600 FHD devices can be 

connected to a Wi-Fi network and configured: 

1) In the Wi-Fi tab, select Enabled for the interface; 
2) Under Operating Mode select the option Station (STA) to connect to an existing Wi-Fi network; 
3) Click on the SSID field and select the Wi-Fi network that will be used; 
4) Under Authentication, select the Authentication protocol to be used: Open (no authentication, 

WEP or WPA/WPA2 PSK; 
5) Enter the Password to access the selected Wi-Fi network; 
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6) Click on Apply after confirming the data entered: 

 

Select the Access Point (AP) option in the Operation Mode field only when the device is to be used as an 

access point to an available Wi-Fi network: 

1) Enter the SSID identification data, the Country, the Channel and the type of Authentication that 
will be applied when distributing the Wi-Fi connection;  

2) Select the type of Encryption on the connection between TKIP, AES or TKIP & AES; 
3) Set a Password to access the Access Point network; 
4) Enter the IP Address and Subnet Mask of the DHCP Server to determine the address range for 

the devices connecting to the Access point; 

 

The maintenance IP (192.168.254.254) is used to recover the connection in 
extraordinary situations when the primary IP is lost. For this reason, when manually 

configuring the device's network interface (Ethernet or Wi-Fi), values other than the 
maintenance IP must be applied. 

5) Click on Apply after confirming the data entered. 
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3G/4G Network settings 

Only the VTR 600 devices and some models of the ITSCAM 600 and ITSCAM 600 FHD devices can be 

enabled for the mobile network, on the 3G/4G interface, and configured: 

1) In the Mobile tab, select the option Enabled for 3G/4G interface; 
2) Enter the APN data if there is no automatic detection, entering custom data whenever it is 

necessary to configure the operator's information. By default the information is: 
a.  APN: http://[operator name].com.br; 
b. User: [operator name]; 
c. Password: [operator name]; 

3) Click on Apply after confirming the data entered: 
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HTTPS settings 

The ITSCAM 600, ITSCAM 600 FHD and VTR 600 capture devices support the HTTPS protocol (port 443), 

which allows communication to be carried out in encrypted form, with a certificate created by the device 

itself or supplied by the user. ITSCAM 450 devices up to firmware version 1.7.0 do not support the HTTPS 

protocol. 

1. In the HTTPS tab, select Enabled; 

 

2. Specify the provider of the key files by selecting Certificate source: 
a. Use the standard certificate: The system will use an embedded certificate generated by 

Pumatronix and a security message will appear in the browser on first access. For the 
settings to be applied, the device must be Restarted by going to System > Update; 

b. Use a specific certificate: The system will use a certificate provided by the user, via a pair of 
public & private key files, by dragging in the Certificate file and Private key file areas. 

3. Click on Apply after confirming the data entered. 
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The use of HTTPS changes the access link to the device from http:// to https:// and the 

device must be Restarted for the change to be applied, by going to System > Update. 

Firewall settings 

Configure the network security firewall by going to the Equipment > Network menu: 

1) In the Firewall tab, select Enabled; 
2) Select the connection Interface used with the port; 
3) Select the Protocol to be applied; 
4) In the Redirect to field, enter a value between 100 and 65535 for which port the service should 

use instead of the default (optional), or leave it blank to not redirect (the value should be 
different from other ports used by the system or plugin and other redirects); 

5) Click on Apply after confirming the data entered. 
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Route settings 

Configure Routes when it is necessary to access remote IP subnets or those not directly connected to the 

network interface, which can be accessed using the Default Gateway or the specified route shown in the 

Diagram. 

1) Select the Route tab; 

 

2) Add a route by clicking Add+;  
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3) View by clicking on Diagram; 

 

4) Or edit the Address, Mask, Gateway and Interface data by clicking on the "+" to the left of the 
route; 

5) Click on Apply after confirming the data entered. 
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Integration with DDNS service 

By upgrading to firmware version 1.4.0 and above, it is possible to integrate the network connection with 

a DDNS (dynamic DNS) service provider: 

 

Figure 10 - Equipment > Network menu screen when configuring the DDNS network 

1) In the DDNS tab, select the Enabled option; 
2) Fill in the fields with the details of the DNS Service Provider, the User and Password for accessing 

the provider and the Hostname, including the domain name; 
3) Click on Apply after confirming the data entered. 

Access Management 

Capture devices allow greater control of access and changes made to the device, as multiple users can be 

created. Users configured with the Administrator profile can configure the equipment, users and view 

images. Users with an Operator profile can view images and settings. To manage active users, access 

System > Users: 

 

Figure 11 - User management home screen 
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1) Create a new user by clicking Add+; 
2) Edit the data of the existing user by clicking on the Edit button; 
3) Identify with a unique Name using between 4 and 200 characters, with letters and numbers and 

no spaces; 
4) Create an access Password containing between 4 and 200 characters, numbers, letters and 

special characters or leave it blank to keep the current password; 
5) Validate the edit by clicking Apply. 

 

 

The factory default user and password should be changed for better access control and 

greater security. 

Date and Time 

The Date and Time settings can be accessed via the Equipment > Date and Time menu and can be made 

manually or via an NTP server. 
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Figure 12 – Equipment > Date and Time menu screen 

Servers 

The devices can automatically send the images to an FTP server or to ITSCAMPRO, for example. 

1) Go to the Equipment > Servers menu; 
2) Select the tab corresponding to the server to be configured: FTP, ITSCAMPRO, Cougar, Lince or 

REST API Client; 
3) Check Maintenance for the steps to restore the system to factory defaults, should any errors 

occur while configuring the servers. 

FTP servers 

1) Enable the FTP server by clicking Enable FTP; 
2) Select the Protocol to be used from the options: 

a. FTP: Basic file transfer protocol; 
b. FTPS: SSL/TLS secure file transfer protocol; 
c. SFTP: SSH file transfer protocol. 

3) Fill in the IP Address and access Port; 
4) Define a User and Password; 
5) Enable Anonymous Mode when not using username and password; 
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6) Adjust the quality of the JPEG image when saving via FTP by selecting it in the Quality field; 
7) Change the code in File names to customize the name of the file with information from the 

capture. To ensure that the name is in the correct format, a validation mechanism has been 
implemented that indicates if any field is filled in incorrectly. To consult, expand the Detailed 
help option; 

8) Enable the Show advanced options option and check/adjust the storage options that the FTP 
upload service will use: 

a. Local TTL: If it is not possible to connect, the device will temporarily keep the images for 
the specified time; 

b. Local buffer size: If it is not possible to connect, the device will keep the images 
temporarily, limited by the size specified; 

c. Transfer timeout: time limit for an individual FTP transfer; 
d. Interval for transfers: After uploading all the images, the device disconnects from the 

FTP server and only reconnects after the specified time; 
9) Click Apply after checking the data entered. 
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ITSCAMPRO Server 

Devices can be enabled to send captures to an external ITSCAMPRO server: 

1) Select the Enable ITSCAMPRO option on the ITSCAMPRO tab; 
2) Fill in the IP Address of the ITSCAMPRO server, which must be a domain name or a valid IPv4 

address; 
3) Enter the access Port, between 1 and 65535; 
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4) Select Legacy Send Mode (ITSCAM 400) when the P0 protocol is to be used for sending data. 
This mode is compatible with ITSCAM400 and should only be used on legacy systems; 

5) Click Apply to validate the data entered; 
6) Check in Status that the server is Connected. 

Cougar Server 

1) In the Cougar tab, select the Enable authentication option; 

 

2) Set a Password to authenticate with Cougar, using up to 64 characters, as Cougar can configure 
multiple aspects of the device; 

3) Click Apply after checking the data entered. 

Lince server 

1) In the Lince tab, select the Enable Lince option; 
2) Select the server operating Environment from the options: Development, Homologation, 

Production or Other; 
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3) Enter the desired endpoint by entering the desired URL for sending the captures via the Lince 
server. Example: lince.app.br or lince.app.br:1443; 

4) Enter a Client Identifier for the Lince server; 
5) Enter an Authentication Code for the Lince server; 
6) Set the Lince server Response Timeout between 2,000 and 15,000 milliseconds; 
7) Check the Login status of the last login attempt to send records; 
8) Select the Send image without OCR and Classifier option so that images without recognition are 

also sent; 
9) Click Apply after checking the data entered. 

 

REST API Client Server 

The devices support sending captures to a generic HTTP server, resizing the image and retrying sending. 

1) In the REST API Client tab, select the Enable REST API Client option, which allows sending 
captures to a generic HTTP server; 

a. Under Predefined settings., select a preset to apply a pre-configuration to certain fields 
by clicking on the Load button; 

2) Select the HTTP Method of the custom request from GET, POST and PUT; 
3) Enter the URL for the custom request, indicating the schema, host and path filled in separately; 
4) Enter the Query parameters for the custom request by clicking +; 

http://lince.app.br/
http://lince.app.br:1443/
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5) Enter additional headers for the custom request in Header by clicking + and entering name and 
value; 

6) Select the Custom body request variant between Singlepart and Multipart; 

 

7) Select the custom request Body Type (Content-Type header is added automatically) from the 
JSON, JPEG and Form (URL encoding) options; 

8) Check and edit the custom request Body Data (Content-Length header is added automatically) 
by replacing the variables with variable names surrounded by double braces, considering the 
variables available in the detailed help; 

9) Select the JPEG Quality that is sent in the body between Standard or between 5% and 95%; 
10) Select the JPEG Resolution that is sent in the body, bearing in mind that an image ratio different 

from the original will cause stretching when resizing (if this is a problem, it will be required to 
select an image crop with the same ratio); 
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11) Enter in Timeout the time interval, in milliseconds, in which the custom request is canceled if 
there is no response from the server; 

12) Indicate the number of Retries that are performed on the personalized request again in the 
event of a failure. Note that variable substitution errors do not count as failures; 

13) Select whether the device should Send No-OCR captures, considering that captures in which 
there is no recognition of license plate characters will be sent; 

14) Check Status for information about the last custom request made by the REST API Client. 

 

Plugins 

Importing plugins directly via the web interface and configuring more than one port with external mapping 

is possible for ITSCAM 600, ITSCAM 600 FHD, VTR 600 devices. The VTR 600 is factory-installed with the 

ITSCAMPRO Mobile plugin. 
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The import of plugins requires that an ext4 formatted SD card be inserted in the capture device. To format 

an inserted card: 

1) In the System > Maintenance menu, go to the Storage tab: 
2) Check Storage Usage to see if there are any files saved on the SD card; 
3) Only click Format SD card if it is certain that the plugin files can be overwritten and replaced; 

 

If the SD card is not present, the device will display the following error message: 

 

Figure 13 – Error message displayed if SD card is not present 

Proceed with the installation of plugins after formatting the SD card, following the steps: 

1) Go to System > Plugins; 

 

2) Click or drag a .tar file into the New Plugin area; 
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3) Enter the Name of the plugin that describes its use; 
4) Configure the plugin's Environment variables by clicking on Add environment variable; 
5) Click Add port mapping when an internal container port needs to be exposed on the device, 

according to the plugin in use; 
6) Click Install after checking the data entered. 

 

Image Profiles 

The Daytime and Nighttime image capture configuration profiles are the factory defaults. The settings 

applied to each parameter of an image profile can be accessed via the Image > Profiles menu: 

 

Figure 14 – Image Menu Screen> Profiles 

1) Enable the option Enable automatic transitions to change between profiles automatically 
according to internal settings and lighting conditions for optimum image quality in any situation; 

a. Use one profile for captures with ambient light (daytime) and another for captures with 
artificial lighting (nighttime), as recommended, and it is possible to register up to four 
Image Profiles, each with its own set of settings; 

b. Select the Level Smoothing to be applied when switching between profiles; 
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i. None: Level changes are made instantly when profiles are changed; 
ii. Simple: level change is performed using a smoothing time during the profile 

change; 
iii. Set the Time for level smoothing in the automatic transition between profiles, in 

milliseconds; 

 

The existing settings for an image Profile are available in tabs and are saved automatically. The initial tab 

labeled General contains the Identification and Text Overlay settings on the image: 

1) Click Add+ under Image Profiles to create new image profiles (it is recommended to configure 
existing profiles before creating new ones); 

2) Or click on the Edit button for the profile to be configured; 
3) Identify the Profile by assigning a Name and adding a Description; 
4) Enable the Photos caption option to apply a text overlay to all generated photos; 
5) Enter a String of up to 1024 characters in the Photos caption text field. Go to the Detailed help 

field to check the values that can be entered as captions. 

 

Figure 15 – Image Menu Screen> Profiles 
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Lens 

The Lens tab contains the Zoom and Focus, Autofocus and Filter settings. 

 

Keep the Automatic Iris option (available on LM models) disabled during the focus 

adjustment process, to obtain better results during the image setting process (available 
on the Exposure tab). 

1) Select the Lens tab; 

 

2) Check the Zoom and Focus settings in real time using the Pop-up Preview window; 
3) Select the Zoom rate value, gradually increasing the available buttons until finding the ideal 

value; 
4) Select the distance of the Focus lens, gradually increasing the available buttons until finding the 

ideal value; 
a. Copy the Zoom and Focus settings from the first profile configured, via the Mirror Zoom 

and Focus option, enabling the Use zoom and focus option for the Day profile, available 
on the Lens tab of the other profiles (the profile name is displayed as configured: Use 
zoom and focus for profile [profile name]); 
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5) Adjust the automatic focus by clicking on Autofocus (only available on models with a motorized 
lens), which modifies the focus position until finding the point of greatest image contrast. The 
button remains active while the algorithm is running and resets when it finishes. To stop the 
process, simply deactivate by clicking again on the button. It is suggested to place objects with 
notable edges at the place of use to help the algorithm; 

6) Click Show advanced options to display the advanced Autofocus settings, only in the event of 
an algorithm malfunction; 

a. Long pitch: if the image is not in focus to begin with, the algorithm first runs through the 
entire focus range, with this value as the increment. Reduce this value if the focus range 
is too thin; 

b. Proximity threshold: the minimum contrast for the image to be considered in focus; 
c. Refresh rate: the time it takes for the focus to be correctly applied to the image; 
d. Region of interest: defines the region in which Autofocus will be executed, by default 

only the central region of the image is considered and can be edited by dragging the 
vertices of the default rectangle. 
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The advanced Autofocus options should only be adjusted if the 

algorithm is malfunctioning. 

7) Enable the IR Filter during the daytime to protect the image sensor and because infrared light 
can distort the colors of the image. When using infrared lighting devices, keep the IR Filter 
disabled, ensuring that the image is formed on the sensor; 

8) Adjust the positioning of the device based on the images displayed in Live View. The suggested 
framing for two lanes in the image is to show the ends of the lane, as shown in the examples: 
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Figure 16 – Example of an 

image with the suggested 
framing generated during the 

daytime 

 

Figure 17 – Example of an image with 

the suggested framing generated during 

the nighttime 

 

 

The Zoom and Focus adjustment corresponds to the Image Profile: Zoom and 

focus adjustment must be performed on all Profiles enabled on the device. 

Image Framing 

When the device is attached using a suction cup to the windshield of a vehicle or when it is attached to the 

roof, the image of the device will be upside down in the view, which can be corrected in Image rotation: 

1) Go to the Image > Miscellaneous menu and the settings will be saved automatically; 
2) Go to the Image tab and enable the Image rotation option when installed upside down; 
3) Set the Default Quality value at which the JPEG will be generated; 

 

4) Enable the Image crop option and images will only be generated of the portion of the ROI 
delimited over the preview image. This option does not affect streams and live image viewing 
and is intended to improve the conversion time to JPEG;  
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a. Select the Crop Mode between the options Static (cropping used to imitate a model with 
lower resolution) or OCR (cropping uses the ROI as the default position and if a license 
plate is recognized, keeps the vehicle centered, adjusting the position and maintaining 
the same size); 

b. Display the license plate size reference by clicking on Grid height and specifying the value 
in pixels, following the template shown in OCR; 

c. Check that the Size of the cropped image is the final desired size; 

 

5) Click on the Scenarios tab to configure two-lane surveillance, defining two different scenarios in 
the image generated by the capture device, simulating the operation of two different capture 
devices; 

a. Enter a text at the top of the image, up to 1024 characters, for Scenario 1, by clicking 
on the Caption text in photos field. Go to the Detailed help field to check the values that 
can be entered as captions; 

 

b. Select the Size of the cropped image for Scenario 1 from the available size options; 
c. Display the license plate size reference by clicking on Grid height and specifying the value 

in pixels, following the template shown in OCR; 
d. Check that the caption and the size of the crop are properly set by clicking on the Preview 

crop with overlay text; 
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e. Repeat the steps above, defining the specifications for Scenario 2; 
6) Click on the Signature tab and select Enable digital signature on images and Concatenation mode 

to join the signature to the generated JPEG file; 
7) Copy the public key text, and/or save it in a file for future verification, referring to the private 

equivalent that was saved or generated; 

 

8) Click or drag a file into the Embedded Signature Check to check whether an image with a 
signature in JPEG comments is valid and has been signed by the device itself. 
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Live Viewing 

The web interface has a live image viewer, available in a pop-up window that can be moved to any place 

on the interface screen, or expanded to occupy the entire window. 

 

Figure 18 – Pop-up live view window: 1) Pause live view; 2) Take photo; 3) Level, Gain, Shutter and 

Photo Profile values active; 4) View settings; 5) Full screen; 6) Minimize window 

1) Click Pause live view (1) to pause the live video and the last captured image remains fixed; 
2) Click on the Take photo (2) button to download an instant JPEG file generated from the image 

being captured by the device; 
3) View, at the bottom of the pop-up window, the Level, Gain and Shutter values that are being 

applied to the device and the Image Profile that is active; 
4) Click on the option Display settings (4)button to access the image display options in the pop-up 

window: 
a. Video: displays the image being taken in real time by the device; 
b. Capture: displays the last image captured in the configured parameters; 
c. Grid: displays a grid over the image; 
d. License plates: displays a recognition area about license plates (as shown in the image); 
e. Vehicles: displays a recognition area about vehicles (as shown in the image); 
f. Zoom and focus: displays two bars on the side of the pop-up window, which allows the 

adjust of the image Zoom and Focus. 
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5) Click on the Full Screen option (5) to expand the view and make interface full screen. 

Streams 

The devices offer the option to follow live images captured by the device outside the web interface, 

integrated into a DVR or video monitoring system by setting it in the Video > Streams menu. The ITSCAM 

450 and ITSCAM 450+ devices only allow MJPEG streaming. 

1) Access the settings in the H.264/H.265 tab by clicking on Enabled; 
2) Choose between the H.264 or H.265 encoding options; 
3) Set the Data transfer Bit rate for the stream in bit/s; 
4) Select the Encoding type from the options: 

a. Constant: the value remains the same throughout the duration of the video; 
b. Variable: the value decreases in parts that need less information and increases in sections 

that need a greater amount of data. 
5) Select the Profile that defines the compression standard (only available for H.264 coding) from 

the options: High, Main or Baseline; 
6) Select the Image Source for the flow from the options: 

a. Preview: using continuous image; 
b. Stills: using image captures (or high trigger rate); 

7) Enter a number of frames from an Image Group block. This block is used as a reference for the 
stream encoding process; 
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8) Access the stream configuration options in the MJPEG tab; 
9) Adjust the quality of the images sent by the stream in the Quality field; 
10) Set the Maximum frame rate of images sent by the stream; 
11) Click Apply after confirming the settings entered. 
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Exposure 

1) Find the profile to set-up in the Image > Profiles menu and click Edit;  

 

2) Select the Exposure tab and on this screen, the settings are automatically saved; 
3) Select the target value for the level of image brightness that the device should try to achieve 

using the variables configured as automatic (shutter, gain and/or iris) in Optimal level, 
considering that 0% is equivalent to a black image, while 100% is equivalent to a white image, 
with values between 25 and 40 being recommended, depending on the environment; 

4) Select the Enable region of interest option and define which region of the image should be 
considered for level calculation, especially in scenarios with regions that could hinder the level 
algorithm (e.g. lamps that are too bright, flashing or regions that are too dark); 

5) Enable the Automatic shutter or select the value for the Fixed shutter in microseconds; 
6) Select the automatic Range of shutter values that can be applied by the Optimal Level algorithm, 

in microseconds; 

 

7) Enable Gain by clicking on the Automatic Gain option, in which the equipment will adjust the 
Gain (within the limits set by the user) to keep the image at the optimal level. When this option 
is deactivated, the Gain to be applied is a fixed value also defined by the user; 

8) Select the Range of gain values that can be applied by the automatic level algorithm, in decibels;  
9) Enable the option of Automatic iris (available for LM models): 
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Color 

It is not recommended to change the color settings, with the exception of the Gamma option. 

1) Find the profile to set-up in the Image > Profiles menu and click Edit; 

 

2) Select the Color tab and on this screen, the settings are automatically saved; 
3) Set the Gamma value, which adjusts the lighting of the image by increasing the gain to darker 

places than lighter ones; 
4) Enable the Auto White Balance option and the Red, Green and Blue balance in the image will be 

adjusted automatically. 
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The Brightness, Contrast, Saturation and Black Level values are factory-set to the ideal 

values in normal image lighting conditions and adjustments are restricted in cases of 

poor quality images generated. Please contact Technical Support for guidance on these 
color settings. 

Transitions between Image Profiles 

When the Enable automatic transitions between image Profiles option is selected, the Level values and 

times applied are used as the basis for the transition. 

1) Find the profile to set-up in the Image > Profiles menu and click Edit; 

 

2) Select the Transitions tab and on this screen, the settings are automatically saved; 
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3) Set the Upper Transition options for the profile being edited: 
a. Select which Profile the upper transition occurs; 
b. Set the Level value at which the upper transition should occur; 
c. Set a Start time and/or an End time for the upper transition; 
d. Set the Timeout for the upper transition so that the device does not oscillate 

unnecessarily between profiles by entering a value between 10,000 milliseconds (10s) 
and 100,000 milliseconds (100s); 

4) Set the Lower Transition options for the profile being edited: 
a. Select which Profile the lower transition occurs; 
b. Set the Level value at which the lower transition should occur; 
c. Set a Start time and/or an End time for the lower transition; 
d. Set the Timeout for the lower transition so that the device does not oscillate 

unnecessarily between profiles by entering a value between 10,000 milliseconds (10s) 
and 100,000 milliseconds (100s. 

Suggested Image Configuration for Profiles 

Capturing quality images is key to getting the full potential out of the ITSCAM 600, ITSCAM 600 FHD, VTR 

600, ITSCAM 450 and ITSCAM 450+ capture devices. For this reason, a suggested image configuration is 

presented in the Visible Light (Daytime Profile) and Infrared Light (Nighttime Profile) situations, which can 

be used as a starting point for adjusting the equipment. 

Images taken at nighttime and/or with the aid of artificial infrared lighting (Nighttime Profile) require image 

settings that highlight the details of vehicles and license plate characters, and the suggested image setting 

can be used as a starting point for adjusting the equipment and checking that the lighting device is 

activated. 
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Parameter 

Suggested value in Daytime 

Profile (Visible Light) 

Suggested value in 

Nighttime Profile 
(Infrared Light) 

Optimal level 40% 

Region of Interest Disabled 

Automatic Shutter Enabled 

Minimum Shutter 66µs 

Maximum Shutter 1000µs 500µs 

Automatic Gain Enabled 

Minimum Gain 1dB 

Maximum Gain 30dB 

Automatic iris (on LM models) Enabled 

Multiple Exposures (Trigger*) Disabled 

HDR** Disabled 

Gamma 130 25 

Gloss 0% 

Contrast 0% 

Saturation 0% -100% 

Black level 20 

Automatic white balance Enabled 

Enable automatic transitions*** Checked  

Profile (Upper Transition) Daytime 

Level (Upper Transition) 40 30 

Timeout**** 60,000ms 1,000ms 

Profile (Lower Transition) Nighttime 

Level (Lower Transition) 20 10 

Timeout**** 60,000ms 1,000ms 

The captures generated by ITSCAM are determined by the Event configured and within the specified Minimum 

interval between triggers. 

**Only devices with the S6 sensor have this functionality. 

***The settings shown for the automatic transition between profiles must be made in the Transitions tab of the 

corresponding profile. 

****It is advisable to set the Timeout close to 1 minute (by entering a value of 60,000ms in the interface) so that 

the device does not oscillate unnecessarily between configuration profiles. 
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Inputs and Outputs 

The ITSCAM 600, ITSCAM 600 FHD and VTR 600 devices have 4 ports that must be configured by software 

as inputs or outputs (IOs), with IO1 and IO2 dedicated to controlling the lighting device's trigger and IO3 

and IO4 available for the installation of external sensors, such as loops and light barriers, which identify 

the moment of image capture (trigger). To set-up the use of each IO port: 

1) Access the settings in the menu Equipment > Inputs and outputs; 
2) Locate the Port to be configured;  
3) Click on the corresponding Edit button; 

 

4) Select the Function as Lighting device/flash output when the IO port is used to flash the lighting 
device (preferably ports 1 and 2): 

a. Select the lighting device model: ITSLUX, WHITELUX, WHITELUX (video) or, if the 
lighting device is from another manufacturer, None/other; 

b. Set the Flash Trigger Delay value to align the image capture with the flash at its peak 
light output on equipment that has a trigger delay. 

 

5) Select the Function as a General-purpose input/output when receiving a loop signal or light 
barrier (preferably ports 3 and 4): 

a. Select the Port Type as Input (example: when receiving a loop signal or light barrier); 
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b. Select the Port Type as Output (example: when triggering gates or alarms); 
i. Select Output value as On to activate the output signal; 
ii. Select Output value as Off to deactivate the output signal; 

6) Apply the port settings by clicking Apply. 

 

ITSCAM 450 and ITSCAM 450+ Inputs and Outputs 

The ITSCAM 450 and ITSCAM 450+ devices have 2 Inputs and 2 Outputs, which are available to control 

the lighting device triggering or to install external sensors, such as loops and light barriers, which identify 

when the images are captured (trigger). To configure the outputs, access the menu Equipment > Inputs 

and outputs: 

1) Locate the Port to be configured and click the Edit button; 
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2) Select the Function as Lighting device/flash output when the output port is used to trigger the 
lighting device flash; 

a. Select the Lighting device model as ITSLUX and, if the lighting device is from another 
manufacturer, None/other; 

b. Set the Flash Trigger Delay value to align the image capture with the flash at its peak 
light output on equipment that has a trigger delay. 
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3) Select the Function as General-purpose input/output when used, for example, to activate a gate; 

 

a. Select Output value as On to activate the output signal; 
b. Select Output value as Off to deactivate the output signal; 

4) Apply the port settings by clicking on Apply. 

Trigger 

1) Find the profile to set-up in the Image > Profiles menu and click Edit; 
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2) Select the Trigger tab and on this screen, the settings are automatically saved; 

 

3) Select the Enabled option to configure image capture according to the configured Event 
4) Select Event as Constant to generate a continuous stream of image captures at the highest rate 

the device can handle; 
5) Select signal input Event from the options: 

a. Rising edge: generates an image capture when the signal is activated; 
b. Falling edge: generates an image capture when the signal is deactivated; 
c. Rising and falling edge: generates an image capture when the signal is activated or 

deactivated; 
d. High level: generates image captures continuously as long as the signal level is high; 
e. Low level: generates image captures continuously as long as the signal level is low; 
f. Select the input Port of the signal used for the trigger, configured in Inputs and Outputs; 

6) Select the Event as Motion to activate the Motion Detector functionality, which generates image 
captures without the need for external sensors, while motion is being detected: 

a. Set the Minimum interval for separation between triggers, in milliseconds; 
b. Set the Threshold value (from 0 to 100) required to activate the Motion Detector; 
c. Select Enable region of interest to delimit the area of the image that should be considered 

in the motion calculation. 

Checking the Images Generated 

It is possible to manually generate a capture and view it, in order to check the local lighting, daytime or 

nighttime, by accessing the Equipment > Images menu: 

1) Select the Trigger tab and the last capture made is displayed, waiting for the last capture to be 
updated when necessary; 
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a. Click on download to download an instant JPEG image of the capture made by the device; 
b. Click on Image metadata to view the metadata of the generated image; 

 

2) Go to the Snapshot tab to access the current settings applied to the image; 
a. Click on Take photo and the generated image will be displayed; 
b. View by clicking on the Metadata of the generated image field; 
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3) Make the necessary adjustments using the information from the current image settings. 

Multiple Exposures 

1) Find the profile to set-up in the Image > Profiles menu and click Edit; 

 

2) Select the Trigger tab and on this screen, the settings are automatically saved; 
3) Enable Multiple Exposures by clicking Enabled to take multiple shots simultaneously with 

different flash, shutter and gain settings. If disabled, only one exposure is taken per trigger, 
without flash and with shutter and video gain; 

4) Click on Add+ to create an exhibition (up to 8 per profile); 
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5) Select the exposure to display its settings; 

 

6) Select the Flash power, always corresponding to a percentage of the initial shot (this option is 
available for the Pumatronix ITSLUX range of lighting devices); 

7) Select the Shutter percentage (exposure time of the image sensor), generating images with a 
variation in the amount of light captured; 

8) Select the Gain percentage (digital post-processing), which allows to lighten or darken the 
images. 

Recognition (OCR Reading) 

The images captured can provide automatic recognition of the license plate of the vehicles in the images 

(OCR) and the type of vehicle identified (Classifier). In this way, JPEG images are delivered with the 

comments field of the file containing the license plates identified, the type of vehicle identified (motorcycle, 

car, truck and bus) and the instantaneous settings of the equipment. 

1) Go to the Equipment > Recognition menu; 
2) Select the Jidosha tab and click Enable OCR; 
3) Access the setting options in the General tab: 
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a. Set the number of Processing threads that will be used to process the OCR; 
b. Set the maximum size of the OCR Processing Queue (smaller values reduce latency while 

larger values reduce frame loss in high flow situations); 
c. Set the Recognition Timeout (images without a license plate or with hidden characters 

cause the algorithm to continue searching for the license plate until the specified time is 
reached); 

d. Set the OCR Processing Mode to faster or more precise; 
e. Set the Maximum number of plates per image, determining the maximum number of 

plates that can be read in the same image;  

 

f. Select the Type of plate of the vehicles that should be searched for by the algorithm in 
the images, considering the pattern of license plate letters and numbers, which are 
different for vehicles and motorcycles (in frontal installations, motorcycle license plates 
are not captured);  

g. Select the Country of the plate of the vehicles in the images. For OCR processing of 
license plates from countries other than Brazil, please contact Pumatronix technical 
support. ITSCAM with embedded OCR performs the processing for Brazilian license plates 
only. 

4) Select the Region of Interest tab and click Enable region of interest: 
a. Enable the Grid Height option, located just below the image; 
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b. Set 10 for the Grid height (in pixels) 
i. Note the size of the license plate characters in the region of the image marked 

as 1 in the example, i.e. when the vehicles are in the most distant region to the 
capture device. The characters should be approximately the grid's height. If they 
are very different, it is necessary to review the zoom settings; 

 

c. Set 40 for the Grid height (in pixels); 
i. Note the size of the license plate characters in the region of the image marked 

as 3 in the example, i.e. when the vehicles are in the region closest to the capture 
device. The characters should be approximately the grid's height. If they are very 
different, it is necessary to review the zoom settings; 
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d. Set 25 for the Grid height (in pixels); 
i. Note the size of the license plate characters in the region of the image marked 

as 2 in the example, i.e. when the vehicles are in the central region of the image. 
The characters should be approximately the grid's height. If they are very 
different, it is necessary to review the zoom settings; 

 

OCR in Region of Interest: OCR is performed only within the drawn region, 

which is slightly shaded in the image. 

5) Select the adjustment options in the Characters tab: 

 

a. Set the Maximum number of low probability characters allowed and characters that are 
identified with reliability lower than the minimum value set are represented by the '?' 
character; 

b. Define the Minimum Character Reliability with the minimum OCR reliability percentage, 
which considers the degree of similarity between the letter identified in the processing 
and a letter in perfect capture conditions. It is recommended to maintain the factory 
standard of 85% minimum reliability; 

c. Set the Minimum character height as 9; 
d. Set the Maximum character height as 60; 
e. Set the Average character height as 20; 

6) Access the setting options in the Perspective tab 
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a. Adjust the Tilt angle of the plates as they appear in the image, removing the 'italics' 
effect, in order to improve OCR efficiency: 

i. Take a photo of a plate in the desired position, using the functionality in 
Equipment>Images>Snapshot, and adjust the tilt value until the characters on 
the plate are aligned with the vertical axis of the grid; 

b. Adjust the Rotation angle of the plates as shown in the image to improve OCR efficiency: 
i. Take a photo of a plate in the desired position, using the functionality in 

Equipment>Images>Snapshot, and adjust the rotation value until the characters 
on the plate are aligned with the horizontal axis of the grid; 

7) Click Apply to validate the entered information. 

Classifier 

1) Go to the Equipment > Recognition menu; 
2) Select the Classifier tab and click Enable Classifier for the device to analyze the captured images 

in real time and evaluate the content present in the images. This analysis aims to distinguish 
motorcycles, cars, trucks and buses from images that show only the road; 

a. Set the number of Processing threads; 
b. Set the size of the image Processing queue; 
c. Set the Minimum reliability (for identifying/classifying the vehicles in the images); 
d. Enable the option to Run only on the first exposures and the Classifier recognition will 

be processed only on the first exposure, when the Multiple Exposures option is enabled, 
which changes the lighting on the first exposure, enough to distinguish the vehicle and 
the other exposures have adequate lighting for license plate recognition; 

3) Select the Scenario: 
a. Panorama for capturing up to two lanes; 
b. Close-up for a single lane; 

4) Select Enable Reading of Vehicle Characteristics to have Classifier process the reading of vehicle 
characteristics such as brand, model and color. This option can increase processing time; 
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5) Select the Enable object tracking option to generate a high-precision virtual loop (virtual 
trigger): 

6) Create the Virtual Trigger Regions which are made up of 3 pieces of information: 2 points 
(indicating a line) and a direction (represented by the third point of the triangle), indicating that 
vehicles crossing the line defined by the two points and following the direction indicated by the 
triangle generate the capture of an image, characterizing the Virtual Loop (virtual trigger): 

a. + (Add region): Add a new region. This configuration is limited to a maximum of 4 
regions; 

b. - (Remove region): Remove selected region. This action can also be performed using the 
'delete' key on the keyboard; 

c. ⇅ (Rotate region): Changes the direction of the selected region. This function allows the 
creation of separate loop points for each lane and indicates the direction of vehicle flow 
in order to generate a precise virtual loop, based on the class of the objects; 
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Majority Vote 

1) In the Majority Vote tab, access the adjustment options by clicking on Enable majority vote when 
the Multiple Exposures feature is enabled and with the aim of the plate resulting from the OCR 
reading considering the most reliable detection for each character; 

 

2) Enable the option Send only the exposure with the best recognition so that only the image with 
the best recognition index is sent; 

3) Set the Maximum number of different characters tolerated to consider two license plates as 
being the same; 
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4) Set a time, in seconds, for the Minimum interval between recognizing identical license plates; 
5) Select Enable filtering using Classifier which allows the use of the Classifier recognition and only 

images with a vehicle are generated; 
6) Click Apply to validate the entered information. 

Licenses 

Analytics licenses can be updated directly via the web interface, either for automatic recognition of the 

license plate of the vehicles in the images (OCR) or for recognition of the type of vehicle identified 

(Classifier). 

1) Go to the System > Licenses menu to update the licenses; 

 

2) Click or drag the file in .lic format to the License Upload area, provided by Support or Commercial 
departments, when available; 

3) Click on Apply; 
4) Confirm on the reboot prompt if it is possible to reboot the system after applying the license: 

 

5) Wait for the file to load completely. 
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Monitoring 

The capture device can be monitored remotely using the SNMP protocol, configured directly via the web 

interface. 

1) Go to the System > Monitoring menu; 
a. Select the Enable SNMP agent option to enable the integrated SNMP agent; 
b. The Enable SNMPv2 option enables version 2 of the SNMP protocol. As SNMPv2 is 

insecure by default, SNMPv3 should be used when possible. 
c. The Enable SNMPv3 option enables version 3 of the SNMP protocol. 

2) Set a Security name (user) (this field is mandatory); 
3) Set an Authentication Password with the authentication protocol is SHA256 (this field is 

mandatory); 
4) Set a Privacy Password with the privacy protocol is AES128 (this field is mandatory); 
5) Click on Apply after confirming the data entered; 

 

Maintenance 

The Backup, Restore, Factory Defaults and Automatic Reboot maintenance options are available via the 

System > Maintenance menu. 

1) Locate the Backup field to save a backup file of the settings, which can be restored on the device 
itself or to import the configuration to other devices; 

a. Select the settings that will be saved in the backup file; 
b. Click on Download backup file; 
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2) Locate the Restore field to use a backup, in which case the current settings will be overwritten 
by the information saved in the file; 

a. Click or drag a file in .bkp format; 
b. Wait for the file to load and for the device to reboot; 

3) Locate the Factory Defaults field to restore the factory settings in the event of a device 
malfunction or incorrect settings; 

a. Select the settings that will be reset to the factory default; 
b. Click on Apply default settings; 
c. Wait for the device to reboot; 

 

4) Locate the System Logs field to download a .zip file with the main system logs: system, memory 
usage, disk usage, CPU usage, connected time and the ITSCAMPRO mobile plugin. The file is 
encrypted, so it must be decrypted using the key provided: 
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a. Click on Download log file; 
b. Unzip the zipped file; 
c. Access the text files, locating the data from each log separately. 

5) Program the Automatic Reboot of the device on a scheduled day and time or periodically for 
improved system: 

a. Select Enable scheduled reboot to restart the system at the specified days and times; 
i. Choose one or more Weekdays for the system restart; 
ii. Set a time for rebooting the system; 

b. Select Enable periodic reboot to restart the system whenever it is on for longer than the 
specified interval; 

i. Set a range between the available options. 

 

3. API REST 

The capture devices have API REST to access the images and settings of the equipment. The API is 

documented in OpenAPI 3.0 format and the latest version is available at devices' own web interface through 

the “API Documentation” option in the left menu or directly via the 

http://192.168.254.254/protected/itscam.yaml endpoint. The itscam.yaml file can be imported by API 

testing tools like Postman and Insomnia. 

4. COUGAR Communication Protocol (Socket) 

The Cougar protocol is an integration interface based on TCP socket connections and the main 

functionalities made available through this API are: device control and configurations; receiving images and 

metadata from vehicle ticket records. The protocol has the following features: 

http://192.168.254.254/protected/itscam.yaml
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• Modular implementation 

o All messages will share a common header, making it easier to implement the low-level 
interpreter; 

o Use of the JSON format, allowing all the fields in some settings to be filled in automatically; 
o Implementation of metadata and extra functionalities in the same command, without interfering 

with operation; 

• Asynchronous messages 

o Metadata can be sent without interfering with settings communication; 
o Facilitates the creation of GUIs or other services with a high rate of simultaneous events; 

• Connection customization 

o Information is only sent when requested, reducing bandwidth consumption; 
o Image metadata can be sent separately, making it possible to receive only metadata, only the 

image or both; 
o Complete metadata is sent during JPEG processing, improving event timing and bandwidth 

usage; 
o Allows the connection to use other binary JSON formats to reduce the amount of data 

transmitted; 
o More secure connections by requiring a password. 

Connection and Messages 

Cougar is implemented using TCP port 60.000. By default, the server will not send any data until it is 

configured to send it or as a response to a request, except for the server shutdown indication. 

All data sent is encapsulated in a message and every message contains a header and a body. Data is 

formatted with the most significant byte (MSB) first, also called Network Byte Order. The message structure 

is: 

 

• Initial byte 

o 8 bits; 
o Fixed value of 102 (0x66); 

• Body size 

o 32 bits with no signal; 

o Contains the size of the message body (without CRC); 

• Operation 

o 16 bits with no signal; 
o Describes operation performed or type of message in the body; 

• ID 

o 32 bits with no signal; 
o "Unique" transaction identifier (possible reuse of IDs with count scrolling); 
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o Responses to requests have the same ID as the request. 
o Incremental value, with an increment of 2; 
o The client must start counting at 0. Server starts counting at 1; 

• CRC 

o 16 bits with no signal; 
o XMODEM format (polynomial: 0x1021, initial value: 0x0000, residue: 0x0000); 

▪ Refer to the CRC16 XMODEM calculation example. 
o Calculation for sending done from the initial byte to the ID (11 bytes); 
o Enables checking by running the algorithm only once on the entire header (13 bytes); 

▪ The header's CRC will always return 0. 

• Body (optional) 

o Size described in bytes in the header; 

• Body CRC (if there is a body) 

o 16 bits with no signal; 
o XMODEM format (polynomial: 0x1021, initial value: 0x0000, residue: 0x0000); 
o Calculation made only for the body. 

General definitions 

Important details of the device's implementation: 

• The device has 4 "dry I/Os" (usually called GPIOs), which can be set to: 
o Input of image capture signals (Trigger); 
o Output for activating equipment (gates, signaling, etc.); 
o Flash drive output; 

• The device has 2 serial interfaces that can be set up as RS-232 or RS-485 (usually RS-232 on serial 
1 and RS-485 on serial 2). 

• Captured images can be separated into 3 categories: 
o Preview: 

▪ When there are no settings, the images are Preview; 
▪ Main source of video streams; 
▪ No flash trigger; 
▪ No OCR processing or vehicle detection; 
▪ Used for motion detection and image brightness adjustment; 

o Snapshot: 
▪ Request made by the client (Cougar, WEB or Pumatronix Protocol); 
▪ Multiple exposures (1 to 8): Flash, shutter and gain can be customized in the request; 
▪ Processing pipeline where OCR and other analyses are carried out; 
▪ The image is never filtered (there is always a response to the client); 

o Trigger: 
▪ Request made automatically (via rising/falling edge of signal, motion detection, etc.); 
▪ Multiple exposures (1 to 8): Flash, shutter and gain customized in advance via REST/WEB or 

Cougar; 
▪ Processing pipeline where OCR and other analyses are carried out; 
▪ Image can be filtered if set not to forward images without vehicles (majority vote); 

• The equipment can take between 1 and 8 exposures from a single event, each with its own shutter 
and gain, which in turn can be set by the user or depend on the current value, and each can trigger 
up to 4 independent flashlights with power control. 



R
e
v
is

io
n
 1

.2
.0

 

 

 

Integration Manual  

Capture Devices 

 

 

64 

www.pumatronix.com 

Operations 
Type Name Value Comments 

General NACK 1 (0x0001) Message failure / keep-alive 

Events 

SHUTDOWN 256 (0x0100) Equipment/connection disconnecting 

EVT_TRIGGER 257 (0x0101) Trigger metadata 

JPEG_TRIGGER 258 (0x0102) Trigger image 

EVT_SNAPSHOT 259 (0x0103) Snapshot metadata 

JPEG_SNAPSHOT 260 (0x0104) Snapshot image 

EVT_PREVIEW 261 (0x0105) Preview metadata 

JPEG_PREVIEW 262 (0x0106) Preview image 

EVT_PIPE_START 263 (0x0107) Pipeline image input 

EVT_GPIO 264 (0x0108) Changing GPIO inputs 

EVT_SERIAL 265 (0x0109) Data received on serial 

Requests 

SET_OPT_STR 512 (0x0200) Section setup 

SET_CALLBACKS 513 (0x0201) Callback setup (events) 

SET_JPEG_CFGS 514 (0x0202) JPEG conversion settings 

TRIGGER_SNAPSHOT 515 (0x0203) Request Snapshot 

GET_LASTFRAME 516 (0x0204) Request last frame (Preview) 

AUTHENTICATE 517 (0x0205) Client authentication 

SET_SERIAL_CFGS 518 (0x0206) Serial interfaces setting 

SEND_SERIAL_DATA 519 (0x0207) Sending data via serial interfaces 

SET_EQUIP_CFGS 520 (0x0208) General equipment settings 

The body of all messages has one of the following formats: 

• None: (empty body [0 bytes]) 
o Used for NACK as a check-alive (to check more quickly if the connection to the server has 

dropped); 
• Binary: Body contains only data in binary format (i.e.: JPEG image) 

o Used for GET_LASTFRAME; 
• JSON: Body contains data only in JSON format or one of the binary variants, set using 

SET_OPT_STR; 
o Used for all other requests and events without a JPEG image (i.e.: EVT_SNAPSHOT); 

• Mixed: Body contains, in order: 
o Metadata size in 32 bits (4 bytes); 

▪ MSB first, as well as for the header. 
o Metadata in JSON format (or variant); 
o Data in binary format, occupying the rest of the space specified by the header; 
o Used in image events (i.e.: JPEG_SNAPSHOT); 
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Descriptions of JSON fields come with the data type in square brackets, along with the default value or an 

example. For example: 

• “field” [string, “value”]: Field explanation. 

For most fields, the response contains all the fields that can be set for a given request. Therefore, to read 

the current settings, send an empty request. 

NACK 

NACK is sent by the server in response to a command when: 

• Response to the NACK command (sent by the client) 
o As the TCP connection often assumes that the server is still operational, using a check-alive 

can check whether the server has shut down more quickly. 
• Invalid operation or not implemented by the server; 
• Unauthenticated client (if the option is enabled); 
• The required operand is not present or is incorrectly formatted; 
• Internal failure; 

A NACK is not sent when: 

• Message header is malformed, with invalid header or body CRC; 
• Non-critical operation fails or is incorrectly formatted 

o i.e.: when trying to set the "trigger" field in the SET_CALLBACKS command to 1, the 
operation fails because it expects a Boolean value (true or false), but does not generate 
errors. It is necessary to check the command response to determine whether the operation 
was successful. 

The body of the response is a JSON with a "reason" field that describes the error encountered for debugging 

purposes, unless it is a response to the NACK command itself (in which case the body is empty). 

SHUTDOWN 

Event sent when the server is shutting down (for example, if the device is rebooting). Sent without 

arguments and does not need to be set to be sent. 

SET_OPT_STR 

SET_OPT_STR sets options related to the client section/connection. For security reasons, this is the only 

setting that only works with the plain JSON format (e.g.: {“string”:”value”}). The settings for this option 

are: 

• “json” [string, “plain“]: how all other messages are sent. That could be: 
o “plain”: Common JSON (ascii string); 
o “bson”: Binary JSON (BSON); 
o “cbor”: Concise Binary Object Representation (CBOR); 
o “messagepack”: MessagePack; 
o “ubjson”: Universal Binary JSON; 

• “respondCfgPath“ [bool, false]: When set, the SET_EQUIP_CFGS operation returns the path that 
was sent to the request (more details in the operation). 
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AUTHENTICATE 

If the server is set up as such, the client will need to send a password for authentication. This option is 

highly recommended for any operating system, as Cougar has access to most of the device's settings. The 

parameter used in the request (which can be omitted if the status is only to be checked) is: 

• “pass” [string]: Password for client access. 

This command does not return NACK. The answer will always contain: 

• “auth” [bool]: True if access to other messages is enabled; 
• “msg” [string]: Message related to the status of the operation. It could indicate, for example: 

o If authentication is not required; 
o If it's already authenticated; 
o If authentication was successful; 
o If the field is poorly formed; 
o If the password is incorrect; 

The only commands that work without requiring authentication are NACK (check-alive), SET_OPT_STR (to 

configure JSON mode) and AUTHENTICATE. 

SET_CALLBACKS 

SET_CALLBACKS sets which events are sent to the client. The fields are: 

• “pipeline” [bool, false]: Enables EVT_PIPE_START events; 
• “trigger” [bool, false]: Enables EVT_TRIGGER events; 

• “snapshot” [bool, false]: Enables EVT_SNAPSHOT events; 
• “preview” [bool, false]: Enables EVT_PREVIEW events; 
• “gpio” [bool, false]: Enables EVT_GPIO events; 
• “triggerjpeg” [bool, false]: Enables JPEG_TRIGGER events; 
• “snapshotjpeg” [bool, false]: Enables JPEG_SNAPSHOT events; 
• “previewjpeg” [bool, false]: Enables JPEG_PREVIEW events; 
• “serial1” [bool, false]: Enables EVT_SERIAL events for serial 1; 
• “serial2” [bool, false]: Enables EVT_SERIAL events for serial 2; 

SET_JPEG_CFGS 

SET_JPEG_CFGS sets the minimum quality and timing for generating JPEGs. The default quality is 

configurable via the REST/WEB interface. The fields are: 

• “trigger“ 
o “quality” [int, configurable]: Quality of images generated from Trigger. 

• “snapshot“ 
o “quality” [int, configurable]: Quality of images generated from Snapshot. 

• “preview“ 
o “quality” [int, configurable]: Quality of images generated from Preview; 
o “mindt” [int, 100]: Minimum time (in milliseconds) between Preview images, to reduce the 

maximum frame rate. 

 

 



R
e
v
is

io
n
 1

.2
.0

 

 

 

Integration Manual  

Capture Devices 

 

 

67 

www.pumatronix.com 

EVT_PIPE_START 

Event sent when a frame enters the photo pipeline (Trigger and Snapshot). Used to facilitate the timing of 

taking photos with an external server. Only the simplest metadata is sent: 

• “framecount” [uint64]: Unique image value, implemented using a counter that increments with all 
images taken (Snapshots, Triggers and/or Previews), reset to zero at server startup 

• “rid” [uint64]: Snapshot sync value. Implemented so that the client can correlate the request made 
(which returns the same value) with the image taken 

• “multexp” 
o “len” [int]: Number of exposures in the multiple exposure group; 
o “pos” [int]: Position of the image in multiple exposures, starting with 0. 

EVT_TRIGGER, EVT_SNAPSHOT, and EVT_PREVIEW 

All these events are sent when the images have finished being processed internally and are delivered to 

the Server. The moment these events are sent, the JPEG conversion of the image also begins, if enabled. 

For Trigger and Snapshot images it is possible to correlate EVT_PIPE_START events using "framecount". 

The metadata for all of them is similar, with the exception of the lack of "rid", "jidosha" and "classifier" data 

for Preview images. The fields are: 

• “framecount” [uint64]: Unique image value, implemented using a counter that increments with all 
images taken (Snapshots, Triggers and/or Previews), reset to zero at server startup; 

• “rid” [uint64]: Snapshot sync value. Implemented so that the client can correlate the request made 
(which returns the same value) with the image taken; 

• “ogSize” 
o “w” [int]: Original image width, in pixels; 
o “h” [int]: Original image height, in pixels; 

• “size” 
o “w” [int]: Image width. Different from the original if the image has been cropped, in pixels; 
o “h” [int]: Image height. Different from the original if the image has been cropped, in pixels; 

• “multExp” 
o “len” [int]: Number of exposures in the multiple exposure group; 
o “pos” [int]: Position of the image in multiple exposures, starting with 0; 

• “shutter” [int]: Shutter exposure in microseconds 
• “gain” [int]: Analog exposure gain in millibels (100x decibels) 
• “stats” 

o “level” [int]: Image level, with a value from 0 to 1000; 
o “meanr” [int]: Average value of the color Red, with a value from 0 to 255; 
o “meang” [int]: Average value of the color Green, with a value from 0 to 255; 
o “meanb” [int]: Average value of the color Blue, with a value from 0 to 255; 
o “stddev” [int]: Standard deviation squared, with a value from 0 to 65535; 

• “time” 
o “setup” [uint64]: Monotonic exposure scheduling time, in microseconds; 
o “exp” [uint64]: Monotonic exposure time, in microseconds; 
o “dma” [uint64]: Monotonic entry time of the exposure into the pipeline, in microseconds; 
o “now” [uint64]: Internal monotonic time of this message, in microseconds; 

• “date” 
o “year” [int]: Year the image was taken; 
o “month” [int]: Month the image was taken; 
o “day” [int]: Day the image was taken; 
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o “hour” [int]: Time the picture was taken; 
o “min” [int]: Minute the image was taken; 
o “sec” [int]: Second the image was taken; 
o “msec” [int]: Millisecond from when the image was taken (taken at the same moment as the 

"time.dma" field); 
• “crop” 

o “x” [int]: Horizontal position of the start of the image crop, in pixels; 
o “y” [int]: Vertical position of the start of the image crop, in pixels; 

• “jidosha” 
o List / Vector 

▪ “plate” [string]: Identified plate; 
▪ “probs” [float list]: Probabilities of each character identified. Same size as the 

identified plate. Values from 0.0 to 1.0; 
▪ “pos” 

▪ “x” [int]: Horizontal position of the plate, in pixels; 
▪ “y” [int]: Vertical position of the plate, in pixels; 
▪ “w” [int]: Plate width, in pixels; 
▪ “h” [int]: Plate height, in pixels; 

▪ “color” [int]: Plate color, 0 for white and 1 for red; 
▪ “moto” [int]: Value 1 for when the identified license plate has the Motorcycle format, 

0 otherwise; 
▪ “country” [int]: OCR country code, using ISO 3166-1; 

• “classifier” 
o List / Vector 

▪ “type” [int]: Type of vehicle identified, based on the Classifier interface: 
▪ 0: Unknown; 
▪ 1: Car; 
▪ 2: Motorcycle; 
▪ 3: Truck; 
▪ 4: Bus; 

▪ “prob” [float]: Identification probability, from 0.0 to 1.0 
▪ “pos” 

▪ “x” [int]: Horizontal position of the vehicle, in pixels; 
▪ “y” [int]: Vertical position of the vehicle, in pixels; 
▪ “w” [int]: Vehicle width, in pixels; 
▪ “h” [int]: Vehicle height, in pixels. 

JPEG_TRIGGER, JPEG_SNAPSHOT, and JPEG_PREVIEW 

All of these events load the converted JPEG image along with some metadata relating to the capture, so 

that the events can be correlated (using the Mixed formatting described above). The quality of the 

conversion is set via the "quality" fields of SET_JPEG_CFGS. For the JPEG_PREVIEW event, only the 

"framecount" and "quality" fields are filled in. For the others, the fields are: 

• “framecount” [uint64]: Unique image value, implemented using a counter that increments with all 
images taken (Snapshots, Triggers and/or Previews), reset to zero at server startup; 

• “quality” [int]: JPEG conversion quality, in percent; 
• “rid” [uint64]: Snapshot sync value. Implemented so that the client can correlate the request made 

(which returns the same value) with the image taken; 
• “multExp” 

o “len” [int]: Number of exposures in the multiple exposure group; 
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o “pos” [int]: Position of the image in multiple exposures, starting with 0. 

TRIGGER_SNAPSHOT 

This operation queues a Snapshot request. By default, when called without any parameters, it uses the 

default parameters configured for the Trigger in the WEB/REST interface. Multiple exposure settings should 

be formatted as follows: 

• “multexp” 
o List / Vector (between 1 and 8 items) 

▪ "shutter" (only one of the options, 100% of the current shutter if not populated) 
▪ “percent” [int, 100] : Percentage of the current shutter; 
▪ “value” [int] : Shutter in microseconds; 

▪ "gain" (only one of the options, 100% of the current gain if not populated) 
▪ “percent” [int, 100] : Percentage of the current gain; 
▪ “value” [float] : Gain in decibels; 

▪ “flash” 
▪ “1“ [int, 0]: Flash percentage at output 1; 
▪ “2“ [int, 0]: Flash percentage at output 2; 
▪ “3“ [int, 0]: Flash percentage at output 3; 
▪ “4“ [int, 0]: Flash percentage at output 4. 

The "shutter" and "gain" fields expect only one of the available options. If both are filled in, the percentage 

will always be used. In addition, in order for the flash to work properly, the outputs used as flash must be 

pre-configured. 

The request response only contains the "rid" (64-bit integer field), which is a unique identifier value for the 

request, serving to correlate requests with the resulting images/processing/metadata. 

GET_LASTFRAME 

This operation uses the last Preview exposure to generate a JPEG. The only input parameter is: 

• “quality” [int, 80] : JPEG conversion quality 

The response to this command fills the body entirely with the converted image or returns NACK if there is 

a problem. For continuous use (video or preview) we recommend using the JPEG_PREVIEW event to 

generate the images. 

EVT_GPIO 

This event is sent when there is a change in the status of the device's "dry" inputs (GPIO). 

The data sent is: 

• “framecount“ [uint64]: Frame in which the event occurred, useful for correlating with exposures; 
• “rising“ [int]: Combination of all inputs where the logic level ranged from 0 to 1; 
• “falling“ [int]: Combination of all inputs where the logic level ranged from 1 to 0; 
• “state“ [int]: Final state of inputs. 

To shorten the messages, the data from all the inputs is placed in the same integer variable, setting the bit 

with the corresponding offset. For example, if input 3 changes state from 0 to 1 and input 1 is high, the 

corresponding event (in "plain" mode) would be: 
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{"framecount":1234, "rising":4, "falling":0, "state":5} 

Therefore, setting the bit corresponding to input 3 would be equivalent to 1<<(3-1) => 4 ("<<" being the 

shift-left operation) and the combination of bits 1 and 3 would be (1<<(3-1))|(1<<(1-1)) => 5 ("|" being the 

bit-by-bit OR operation). 

SET_SERIAL_CFGS 

SET_SERIAL_CFGS sets the serial interfaces. They can be used by more than one client and reconfiguration 

using different parameters can lead to data loss. It is recommended (especially for RS485 connections) that 

all devices on the same bus use the same settings. The available settings are: 

• “serial1” 
o “baud“ [int, 115200]: Interface speed in bits per second (baud); 
o “bits“ [int, 8]: Number of bits in each frame. Valid values are between 5 and 8; 
o “stop“ [int, 1]: Number of stop-bits. Valid values are 1 or 2; 
o “parity“ [string, “n”]: Parity of each frame. Valid values are: 

▪ “n“: No generation or checking; 
▪ “o“: Odd parity; 
▪ “e”: Even parity. 

• “serial2” 
o Same parameters as "serial1". 

EVT_SERIAL 

Event generated when data is received via the serial interface. As there is more than one interface, the 

message format is mixed. In the metadata, it is sent: 

• “pipe“ [string]: Data source ("serial1" or "serial2") 

In the rest of the message (binary format), the received data is sent. Between 1 and 2048 bytes of raw 

data can be sent in each message. Due to internal timings and other factors, messages being received may 

be sent in fragments smaller than the maximum size. 

SEND_SERIAL_DATA 

This operation sends data to the specified interface. The required fields are: 

• “pipe“ [string]: Target interface ("serial1" or "serial2"); 
• “ascii“ [string]: Data in ASCII format (no special characters/bytes) or; 
• “base64“ [string]: Data in base64 format or; 
• “hex“ [string]: Data in hexadecimal format (2 characters per byte, 0-9;A-F). 

Only one of the data fields is used (using primarily "ascii", then "base64" and then "hex" if multiple are 

sent). It is recommended to send only the most convenient format. 

If everything goes as expected, the command will return: 

• “len“ [int]: Number of frames (usually bytes) sent. 
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SET_EQUIP_CFGS 

SET_EQUIP_CFGS is the main interface for controlling equipment settings on the Cougar. To approximate 

the formatting of the REST interface, it controls the image-taking settings, making it equivalent to REST 

endpoints: 

• /camera/misc/readonly/volatile → “equip.volatile“; 
• /camera/misc/readonly/constants → “equip.miscRO“; 
• /camera/misc → “equip.misc“; 
• /camera/autofocus → “equip.autofocus“; 
• /camera/profiles/:id (except creating and deleting profiles) → “equip.profiles“; 
• /camera/profiles → “equip.currProfile“; 
• /camera/transitioner → “equip.transitioner“; 
• /camera/ios → “equip.io“. 

It also controls the Services endpoints: 

• /camera/services/stream → “h264“ and “mjpeg“; 
• /camera/services/ocr → “ocr“; 
• /camera/services/classifier → “classifier“; 
• /camera/services/analytics → “analytics“; 
• /camera/services/ftp → “ftp“; 
• /camera/services/itscampro → “itscampro“; 
• /camera/services/licenses → “license“. 

The (optional) input parameters for this command are: 

• “path“ [string,””]: Root path to consider for the data; 
• “data“ [object/value, {}]: Data to be written to the settings. 

All the settings mentioned above are available in a complete settings tree. Therefore, like all the other 

Cougar settings, it is possible to configure the elements sparsely, configuring only what it is need. This 

means that, from a writing point of view, the following options are equivalent: 

1) {“path”:”analytics.voting.roi1.x0”, “data”:123} 
2) {“path”:””, “data”:{“analytics”:{“voting”:{“roi1”:{“x0”:123}}}}} 
3) {“path”:”analytics.voting”, “data”:{“roi1”:{“x0”:123}}} 

Due to the sheer volume of configurations, when using an empty path in a conventional case, around 800 

elements are answered. This unnecessarily increases the consumption of processing and network resources 

and is therefore not recommended for continuous use. For the examples above, the answers are: 

1) 123; 
2) all settings (~800 elements); 
3) only majority voting settings (~25 elements). 

Due to the volume of configurations, it is recommended to use the REST interface documentation as a 

reference for the parameters of this command. 

APIs available 

Since the protocol is open, it is possible to implement its own version of the client, especially if the 

application does not use one of the languages in which they have been implemented, or if the version made 

available does not meet the requirements of the rest of the application (e.g. python 2 vs. 3, C++ 98 vs. 11 
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vs. 17 vs. 20). Pumatronix provides clients in C++ and Python, for code reference only (contact technical 

support to obtain them). 

General Recommendations 

Configurations can be changed partially/sparsely, without the need to read, modify and write a fixed 

structure. This way, even if new fields are added, client behavior remains consistent. 

For the SET_EQUIP_CFGS operation, the path closest to the settings to be adjusted should be entered, so 

that the return from the operation is as small as possible. It is recommended to get all the settings 

("path":"") only when necessary (for example: when initializing the client logic). 

To implement the protocol independently, it is highly recommended to use a multi-threaded environment 

to handle message reception and interpretation in a separate thread, to reduce latency between data 

reception. If necessary, it is possible to use a threadpool to make interpretation faster in multi-core 

environments. 

All messages are asynchronous, meaning that during the processing of a command (waiting between 

sending and receiving) other messages (events, images or even commands from other threads) can be 

received. 

CRC16 XMODEM calculation example 

// Example implementation of the CRC16 XMODEM algorithm. This example uses a 

// "CRC tab" to precalculate coefficients and optimize performance.   

// It is possible to define the tab as a "magic" value constant. 

// It uses variables defined in <stdint.h> that can be overridden 

// for the system equivalent. They usually are: 

// - uint8_t -> unsigned char 

// - uint16_t -> unsigned short int 

uint16_t crcXMODEM(const uint8_t *c, int numBytes, uint16_t currCrc = 0) { 

    static uint16_t crcTab[256]; 

    static bool init = 0; 

    if(!init){ 

        init = true; 

        for (int i=0; i<256; i++) { 

            uint16_t short_c = i<<8; 

            uint16_t crc = 0; 

            for (int j=0; j<8; j++) { 

                if ( ((crc ^ short_c) & 0x8000) != 0 ) { 

                    crc <<= 1; 

                    crc ^= 0x1021; 

                } else { 

                    crc <<= 1; 

                } 

                short_c <<= 1; 
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            } 

            crcTab[i] = crc; 

        } 

    } 

    for (int i = 0; i < numBytes; i++) { 

        currCrc = (currCrc << 8) ^ crcTab[((currCrc >> 8) ^ c[i])]; 

    } 

    return currCrc; 

} 

5. Open Source Pumatronix Communication Protocol 
(Socket) 

Communication with the devices is via the Ethernet interface, using the Pumatronix UDP and TCP/IP 

communication protocols. The port used to communicate with the external device is 50000. Therefore, the 

application developed to communicate with the device must be configured to send commands using this 

port in the TCP and UDP protocols. 

The UDP protocol is only used to identify devices connected to the network, as it allows broadcast-type 

packets to be sent, which are received by all devices. This allows the image capture device to send its ID 

when it receives this packet. All other commands use the TCP protocol, which establishes a point-to-point 

connection between the control device and the image capture device. Receiving and changing settings is 

secured by transmitting a CRC code. However, most of the responses sent by the equipment do not have 

a CRC. 

The Pumatronix Protocol supports connections that have been developed based on the Dynamic Library 

(dll) and the C++ class for Linux. A Development Kit (SDK) is available at www.pumatronix.com with the 

files needed to develop the application, to download it, go to Customer Area > Technical Support. 
 

Commands 

VIDEO  REQ_DATA SETA_TIPO_SHUT REQ_POSICAO_ZOOM 

VIDEO_CONTINUO REQ_ENTRADA SETA_SHUT REQ_POSICAO_FOCO 

FOTO REQ_GAMMA SETA_SHUT_MAX  

FOTO_INFO_ADIC REQ_GANHO_VISIVEL SETA_TIPO_GANHO  

REQ_CONF_IMAGEM REQ_TEMPO_LIGADO SETA_GANHO  

REQ_CONF_GER REQ_MOV_LENTE SETA_GANHO_MAX  

SETA_DEFAULT REQ_FOCO_IR SETA_NIVEL_IMG  

REQ_CONF_REDE REQ_IO_VIGIA  SETA_ZOOM  

REQ_SITUACAO_DAY_NIGHT REQ_DIR_IO_VIGIA SETA_FOCO  

REQ_ROTACAO SETA_ROTACAO SETA_POSICAO_ZOOM  

http://www.pumatronix.com/
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Commands 

REQ_LENTE_AUTO_IRIS SETA_LENTE_AUTO_IRIS SETA_POSICAO_FOCO  

REQ_MODO_DAY_NIGHT SETA_MODO_DAY_NIGHT SETA_IO_VIGIA  

REQ_SATURACAO SETA_SATURACAO SETA_DIR_IO_VIGIA  

REQ_WHITE_BALANCE SETA_WHITE_BALANCE SETA_GAMMA  

REQ_FOTO_COLORIDA SETA_FOTO_COLORIDA REQ_WB_ATUAL  

REQ_HORA SETA_SAIDA SETA_ZOOM_FOCO  
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